Jump to content

CSV Promble


acquiescefc
 Share

Recommended Posts

OK I needs help and google doesnt help.

 

Step 1 - I receive a CSV file (semi colon separated) text is wrapped as in abc;123;def;12;ab etc etc

Step 2 - I need to do 'text to columns' into excel because i have to remove last four columns and pass it to someone else who adds some new columns replacing what i took out and he sends me back.  Its sent back as CSV format but it appears to me visibly as excel formatted in neat columns not as above.

I believe its somehow formatted with commas but i dont see that, its just in columns.

 

Step 3 - So now i want to save it back to i received at Step 1 in its original format CSV(semi colon separated) abc;123;def;12;ab as above but cant.

 

If i save as Tab delimited text or any other text type it doesnt do what i want. It either saves as excel in neat columns or as text in neat columns with no separators i need it to be in its original continuous unreadable string.

 

Ive tried changing the Regional settings from ',' to ';' but when saving as various things it doesnt seem to work.

File is quite big circa 20Mb so its a frustratinf task to even try options and i have to send this to client.  If its not in format at start they will reject.

 

The guy who does the middle step is cantankerous and hard to nail down in a short window this process happens and is impossible to get to help me on this so want to do it myself.

 

Im not familiar with scripts but didnt think this would be so difficult.

 

Anyone whose heard of this or similar knows anything that might work I appreciate the help.  ta

 

Link to comment
Share on other sites

You can change your global list seperator

 

from your windows start menu, click start and type "Region" (or go to control panel and select region). 

select additional settings

change teh list seperator from a comma to a semi colon

save it

go to excel and export as CSV and it will use semi colon as a seperator

 

 

Link to comment
Share on other sites

15 hours ago, fezman said:

You can change your global list seperator

 

from your windows start menu, click start and type "Region" (or go to control panel and select region). 

select additional settings

change teh list seperator from a comma to a semi colon

save it

go to excel and export as CSV and it will use semi colon as a seperator

 

 

 

 

Yeah i had initially tried this but the results didnt exactly look right, or so i thought.  Spoke to a guy in work y'day who said try this and the output is not wrong it just looks different.

Have to send file today so hopefully its ok.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...